欢迎光临
我们一直在努力

CVE-2020-13957:Apache Solr ConfigSet 文件上传漏洞通告

 

0x01 漏洞简述

2020年10月13日,360CERT监测发现 solr 发布了 solr 文件上传漏洞 的风险通告,该漏洞编号为 CVE-2020-13957 ,漏洞等级: 高危 ,漏洞评分: 7.2 。

攻击者可以通过结合 UPLOAD/CREATE 这两个 ACTION 在 ConfigSet API 上进行未授权操作,可以造成获取服务器权限的影响。

对此,360CERT建议广大用户及时将 solr 升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

 

0x02 风险等级

360CERT对该漏洞的评定结果如下

评定方式 等级
威胁等级 高危
影响面 一般
360CERT评分 7.2

 

0x03 漏洞详情

CVE-2020-13957: 文件上传漏洞

Solr 是 Apache Lucene 项目的开源企业搜索平台。其主要功能包括全文检索、命中标示、分面搜索、动态聚类、数据库集成,以及富文本的处理。 Solr 是高度可扩展的,并提供了分布式搜索和索引复制。

攻击者可以通过结合 UPLOAD/CREATE 这两个 ACTION 在 ConfigSet API 上进行未授权操作,可以造成获取服务器权限的影响。

 

0x04 影响版本

  • apache:solr : 6.6.0 – 6.6.5
  • apache:solr : 7.0.0 – 7.7.3
  • apache:solr : 8.0.0 – 8.6.2

 

0x05 修复建议

通用修补建议

  1. 如果未使用ConfigSets API,请禁用UPLOAD命令,将系统属性: configset.upload.enabled 为 false ,详细参考:https://lucene.apache.org/solr/guide/8_6/configsets-api.html
  2. 使用身份验证/授权,详细参考:https://lucene.apache.org/solr/guide/8_6/authentication-and-authorization-plugins.html
  3. 在SOLR-14663中应用修补程序: https://issues.apache.org/jira/browse/SOLR-146634. 任何 Solr API ,包括管理 UI ,都不向未授权一方公开。设置防火墙,以便只允许受信任的计算机和人员访问。

 

0x06 相关空间测绘数据

360安全大脑-Quake网络空间测绘系统通过对全网资产测绘,发现 Apache Solr 在 全球 均有广泛使用,具体分布如下图所示。

 

0x07 产品侧解决方案

360城市级网络安全监测服务

360安全大脑的QUAKE资产测绘平台通过资产测绘技术手段,对该类漏洞进行监测,请用户联系相关产品区域负责人或(quake#360.cn)获取对应产品。

 

0x08 时间线

2020-10-12 Apache发布通告

2020-10-13 360CERT发布通告

 

0x09 参考链接

  1. [CVE-2020-13957] The checks added to unauthenticated configset uploads in Apache Solr can be circumvented

 

0x0A 特制报告下载链接

CVE-2020-13957: Apache Solr ConfigSet 文件上传漏洞通告

赞(0) 打赏
未经允许不得转载:中国宏阔黑客联盟|白帽黑客|网络渗透技术|网站安全|移动安全|通信安全 » CVE-2020-13957:Apache Solr ConfigSet 文件上传漏洞通告
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏